Published: 2005-06-17
Applies to:
- Content Studio ver. 3.3+
Type: Information
Symptoms
When you add fields to be indexed to an EPT document category the
fields do not appear to be indexed. However if you save or approve a document in
the category it will be indexed properly.
Cause
This problem is likely caused by a lack of permissions for the Content
Studio Service Manager runtime account. When you add a new indexed EPT document
field an event is raised (OnXMLIndexChange) and a background process is started
by the Content Studio Service Manager. This process runs under a dedicated run
time account set by the administrator when Content Studio was installed.
This process will be used as an identity when the index is saved and this
identity needs the APPROVE permission to save published data and WRITE to save
draft data.
Resolution
Ensure that the CS Service Manager runtime account has at least
the READ, WRITE and APPROVE permission on the category to be
indexed.